Android- android sbi communicating with ctk on Synergy enviroment ,can not upload certificate

  1. At present, the CTK tool officially provided by MOSIP is for the Synergy environment. When we tried to upload Device and FTM certificates in the PMP of the Synergy environment, we found that the website did not have any upload function. Additionally https://pmp.dev.mosip.net/ We have also tried PMP for the address, but cannot access the webpage. On what platform should we upload Device and FTM certificates, as well as obtain Mosip certificates?

  2. SBI requires clientid and secretKey to obtain tokens and encryption keys for biological data online. Currently, we use https://api.synergy.mosip.net The following error occurred when downloading the key from the environment:

IdaResponse: {“id”: “string”, “version”: “string”, “responsemame”: “2023-12-06T11:23:38.650Z”, “metadata”: null, “response”: null, “errors”: [{“errorCode”: “500”, “message”: “401 Unauthorized”}]}

What is the reason for the error? If we don’t want to deploy the cluster service provided by Mosip locally, can we use the official services of Mosip to obtain valid clientid and secretKey? If so, please provide a method?

  1. At present, our fingerprint device is a single fingerprint module, and the testing cases on CTK are mainly aimed at multiple fingerprint modes. Please provide the necessary configuration cases for single fingerprint module testing

Hi @nizhuanxinghe

We have updated our team and we will look into this asap to provide you with the right resolution.

Best Regards,
Team MOSIP

Hello nizhuanxinghe;

I had already responded to the above raised query via one to one email. Please do write to me in case of any further clarification.

-Suraj

1 Like