MOSIP Admin Portal Redirection Issue

Hi Team,

We have tried implementing the MOSIP in on-premise environment and also finished setting up the MOSIP cluster. But when we tried login into the admin portal, it is redirecting to the iam URL(keycloak URL) and we are not able to login with the default admin credentials. But we are able to login into the iam URL separately with the same admin credentials. Kindly check and let us know if we are missing something. Please find the below screenshot for your reference.

Kindly get back to me on this.

@reddi3 you need to create user in keycloak with globaladmin role

Hey @reddi3

Yes @mazboko is right here you need to create a user in keycloak with a global admin role and in case if this isn’t working out for you and still facing the issue,I will even ask one my team member to look into this.

Best Regards,

Hello @reddi3 ,

To login to the admin-portal, you need a keycloak user with atleast one of the admin-roles. Visit this link to get the list of admin-roles.

Please follow this video to create a new keycloak user.

I hope It resolves your issue.

Thanks and Regards,

1 Like