Issue in Partner Management Portal v1.2.0.1-B2 - FIXED

I can’t login through the Partner Management Portal. This is all I got

I also have already enabled self registration in Keycloak. But still no way to login.

No errors in Rancher.

Here is an extract of the log file

127.0.0.6 - - [27/Mar/2023:14:01:42 +0000] “GET / HTTP/1.1” 200 894 “-” “kube-probe/1.23” “-”
2023/03/27 14:01:48 [error] 14#14: *2131 “/usr/share/nginx/html/pmp-ui/index.html” is not found (2: No such file or directory), client: 127.0.0.6, server: localhost, request: “GET /pmp-ui/ HTTP/1.1”, host: “X.X.X.X(redacted)”
127.0.0.6 - - [27/Mar/2023:14:01:48 +0000] “GET /pmp-ui/ HTTP/1.1” 404 153 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/111.0” “10.207.102.5,10.42.4.0”
127.0.0.6 - - [27/Mar/2023:14:01:52 +0000] “GET / HTTP/1.1” 200 894 “-” “kube-probe/1.23” “-”
127.0.0.6 - - [27/Mar/2023:14:02:02 +0000] “GET / HTTP/1.1” 200 894 “-” “kube-probe/1.23” “-”

127.0.0.6 - - [27/Mar/2023:14:50:32 +0000] “GET / HTTP/1.1” 200 894 “-” “kube-probe/1.23” “-”
127.0.0.6 - - [27/Mar/2023:14:50:38 +0000] “GET / HTTP/1.1” 304 0 “X.X.X.X(redacted)” “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/111.0” “10.207.102.5,10.42.5.0”
127.0.0.6 - - [27/Mar/2023:14:50:38 +0000] “GET /assets/config.json HTTP/1.1” 200 154 “X.X.X.X(redacted)” “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/111.0” “10.207.102.5,10.206.100.169”
127.0.0.6 - - [27/Mar/2023:14:50:42 +0000] “GET / HTTP/1.1” 200 894 “-” “kube-probe/1.23” “-”

Happy to report that I can now login with a user with a partner-admin role, and the register button is also available.

I was able to fix this by overriding the helm charts values.yaml for all applications.

I created partners_values.yaml, policy_values.yaml and values.yaml and edited install.sh.

install.sh

echo Installing partner manager
helm -n $NS install pms-partner mosip/pms-partner -f partners_values.yaml --version $CHART_VERSION

echo Installing policy manager
helm -n $NS install pms-policy mosip/pms-policy -f policy_values.yaml --version $CHART_VERSION

echo Installing pmp-ui
helm -n $NS install pmp-ui mosip/pmp-ui -f values.yaml --version $CHART_VERSION

partners_values.yaml

istio:
enabled: true
gateways:
- istio-system/public
- istio-system/internal
prefix: /v1/partnermanager
corsPolicy:
allowOrigins:
- prefix: https://pmp.mydomain.com(edited)
allowCredentials: true
allowHeaders:
- Accept
- Accept-Encoding
- Accept-Language
- Connection
- Content-Type
- Cookie
- Host
- Referer
- Sec-Fetch-Dest
- Sec-Fetch-Mode
- Sec-Fetch-Site
- Sec-Fetch-User
- Origin
- Upgrade-Insecure-Requests
- User-Agent
- sec-ch-ua
- sec-ch-ua-mobile
- sec-ch-ua-platform
- x-xsrf-token
- xsrf-token
allowMethods:
- GET
- POST
- PATCH
- PUT

policy_values.yaml

istio:
enabled: true
gateways:
- istio-system/public
- istio-system/internal
prefix: /v1/policymanager
corsPolicy:
allowOrigins:
- prefix: https://pmp.mydomain.com(edited)
allowCredentials: true
allowHeaders:
- Accept
- Accept-Encoding
- Accept-Language
- Connection
- Content-Type
- Cookie
- Host
- Referer
- Sec-Fetch-Dest
- Sec-Fetch-Mode
- Sec-Fetch-Site
- Sec-Fetch-User
- Origin
- Upgrade-Insecure-Requests
- User-Agent
- sec-ch-ua
- sec-ch-ua-mobile
- sec-ch-ua-platform
- x-xsrf-token
- xsrf-token
allowMethods:
- GET
- POST
- PATCH
- PUT

values.yaml

image:
registry: docker.io
repository: mosipqa/pmp-ui
tag: latest

pmp:
apiUrl: https://api-internal.mydomain.com(edited)/

istio:
enabled: true
ingressController:
name: ingressgateway-internal
gateways:
- name: pmp-gateway
protocol: HTTP
portName: http
port: 80
hosts:
- pmp.mydomain.com(edited)
prefix: /

@rcsampang this should have been automatically taken care of when you install MOSIP. The install script was expected to fill this values.

Yes I agree. But somehow in my setup, it didn’t work as expected. I was only able to access and login the partner management portal when I have overridden the Helm charts.

I really can’t explain but I was only able to fix the error in my MOSIP setup after doing the steps I stated above, which is basically just manually providing the values that should have been provided for in the installation script.

The only difference I know of is that I am using the latest helm v3.11.2, is there an issue with that?
I think in my case the --set flag did not override the supplied value, thus when I used values.yaml instead, it was able to provide the correct pmp host and api-internal host for my domain.