Can't run idrepo identity - CrashLoopBackOff (MOSIP version

I tried for several times making idrepo identity application to run but I failed.

I used different Helm chart versions, even changed Docker images, adjusted liveness/startup probes, increase/decrease resources and other usual fix to this issue, Unfortunately no success in making it run without encountering errors.

I look at the logs and I see errors on them, but I do not know how to fix them.

Here is an extract =

@timestamp”:“2023-03-12T14:42:00.010Z”,“@version”:“1”,“message”:“\n\nError starting ApplicationContext. To display the conditions report re-run your application with ‘debug’ enabled.”,“logger_name”:“org.springframework.boot.autoconfigure.logging.ConditionEvaluationReportLoggingListener”,“thread_name”:“main”,“level”:“INFO”,“level_value”:20000,“appName”:“id-repository”}
{“@timestamp”:“2023-03-12T14:42:00.014Z”,“@version”:“1”,“message”:“Application run failed”,“logger_name”:“org.springframework.boot.SpringApplication”,“thread_name”:“main”,“level”:“ERROR”,“level_value”:40000,“stack_trace”:"org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name ‘idRepoProxyServiceImpl’: Unsatisfied dependency expressed through field ‘objectStoreHelper’; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘objectStoreHelper’: Injection of autowired dependencies failed; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder ‘s3.pretext.value’ in value "${s3.pretext.value}idrepo"\n\tat org.springframework.beans.factory.annotation.AutowiredAnnotationBeanPostProcessor$AutowiredFieldElement.inject

I tried fixing this again by overriding the helm chart using values.yaml and pointed to the latest docker image - mosipid/id-repository-identity-service:latest

I did this after reading in the forum about an error with the s3.pretext.value in a docker image fixed with a image.

Now there is a different error -
Exception in thread “main” zip file is empty

I had an idea of fixing this by doing the steps I did in fixing the errors in packetmanager.

In the mosip-helm chart repository I downoaded the raw values.yaml of the helm chart to the mosip idrepo module directory

Then I edited the file to add this line to the file

$COPY_UTIL configmap softhsm-kernel-share softhsm $DST_NS

In the values.yaml configuration I added the line - softhsm-kernel-share



I also edited the docker image to use the latest

repository: mosipid/id-repository-identity-service
tag: latest

then, increased the resources

javaOpts: “-Xms4000M -Xmx4000M”

So I deleted and reinstalled idrepo module with a helm chart override using values.yaml. This is to make sure that changes in will be loaded.

Before that I edited the particularly the line installing idrepo-identity.

helm -n $NS install identity mosip/identity -f values.yaml --version $CHART_VERSION

I had to do this a few times testing different chart versions.

So that I don’t have to uninstall the other working services I used the following commands:

helm -n idrepo delete identity

helm -n idrepo install identity mosip/identity -f values.yaml --version 12.0.1-B2

kubectl -n idrepo get deploy -o name | xargs -n1 -t kubectl -n idrepo rollout status

Don’t ask me why, I can’t explain, but it is working now.

This issue returned after a while, but Once mosip-config repo is updated with the fix as discussed by @vishwa at my packetmanager post

I simply restarted the config-server module and after a few minutes the errors were gone. This issue was also fixed along with the issues in packetmanager, idrepo-identity, resident and even regproc-group6.

Thank you so much, please consider this issue closed.

Warm regards,