Registration Processor Pods Stuck in Completed State

Hi Team,

We have tried setting up the MOSIP infra on On-prem instance and observed few pods in registration processor are stuck in completed state like regproc-pktserver,regproc-salt & regproc-group1. Is this expected behavior of these deployments? We even tried executing the restart script of registration processor module but new pods belonging to above services are not launching. Can you check and confirm this? Kindly revert back to me in case of any queries.

Pls find the screenshot for your reference

Hi @reddi3

Thanks for sharing the query our team member @sowmya695 from the reg proc team will look into this and reply back asap.

Best Regards,
Team MOSIP

Hi @reddi3 ,

regproc-salt status completed is correct as per deployment.
regproc-pktserver,regproc-group1 both status should be running ,but it is showing init 0/1 so whether its started now,Please check it.
if not running status still,Please get logs and attach for both service

Hi Team,
Thanks for your quick response.

The above mentioned pods(regproc-pktserver,regproc-group1) were stuck in completed state. So we have executed the restart script of the registration processor module and the new pods are stuck in init 0/1 state.

When I have described the pods to check the issue, I found out below in the logs

FYI…I have installed nfs-kernel package in all my cluster nodes.

apt install nfs-kernel-server
systemctl start nfs-kernel-server.service

Any solution for this?

Hi team,

The issue is due to both regproc-group1 and regproc-pktserver services using the same PVC using ReadWriteMany access mode which is not supported by longhorn. We are able to find the solution for now by running them in a single node and changing the access mode to ReadWriteOnce. We also tried installing nfsv4 client suggested by longhorn official documentation to overcome this problem,but it didn’t work out. Kindly let us know if there is any other solution.

And also, currently these are the complete list of pods in completed state. Kindly check and confirm which all need to be up and running out of these.

Thanks
Naveen

All these pods in completed lists are correct, they are actual jobs which goes into completed state once done.

For two of the regproc pods can you share the values.yaml being used for deploymement?
also can you confirm if longhorn is installed sucessfully?

Hi @ckm007 ,

Thanks for the confirmation.
Kindly find the links for values.yaml files for the both regproc services below.

mosip-helm/charts/regproc-group1/values.yaml at v1.2.0.1-B3 · mosip/mosip-helm · GitHub

mosip-helm/charts/regproc-pktserver/values.yaml at v1.2.0.1-B3 · mosip/mosip-helm · GitHub

And yes, longhorn has been installed successfully without any issues.

@reddi3 these are the default values … I need the values file used while running install scripts to deploy regproc. Can you please share that?