Failed to launch the pre-registration-ui part in localhost

I have cloned the repo of pre-registration-ui and as per the documentation (README) I run the following commands.

  • npm install / npm install --force
  • ng serve

after installing all the dependencies and running the server, it stops automatically and gives this error.

Workspace extension with invalid name (defaultProject) found.
Error: Could not find the '@angular-devkit/build-angular:dev-server' builder's node package.

I tried to configure the project (as per the documentation) but not able to run it on my localhost.

Any help would be appreciated.

pre-registration -

Dear @SiddhantTotade ,

Welcome to the community and thank you for reaching out. We are looking into your query and one of our expert colleagues will respond shortly.

Best Regards

Hi @sidhant,

As per the error its coming from Angular. Please install the dependent angular packages.
ex: npm install @angular-devkit/build-angular:dev-server

Best Regards,

I have tried the above solution but not getting any results. I have cloned two repositories.

  1. Pre-Registration-UI
  2. Pre-Registration-UI-Develop (develop branch)

The Develop branch is working fine and opening in localhost:4200 with a loading screen. In this I have downgraded the version of angular to 13 which is supported with the node and npm version 14.17.3 because if I not then it will throw an error which says Upgrade your angular version.

After running the command ng server it works perfectly.

The problem is comming with the Pre-Registration-UI (not develop branch). I have already installed the supported versions of Node, NPM and Angular but when I run the command ng serve it will throw error.

Could not find the '@angular-devkit/build-angular:dev-server' builder's node package.

This error is comming when I try to run the project.

Also, please suggest me which repository I have to follow for the Pre-Registration part with the branch name.

Hi @Sidhant,

You can use either use pre-reg UI develop branch or release branch. Both has same code

Since you already used develop branch and its working fine. You can continue with it, No need to run from other branch.

Also please note that Pre-reg UI is developed using
Angular version 8.19.2.
Angular CLI: 13.3.2
Node: 14.17.3
Package Manager: NPM 6.14.13

Check if your global version and local versions are same.

Please use this Repo for Pre-reg UIPre-reg UI , release- branch